Skywars autofarm is broken

Incident Report for Hawk HUB

Resolved

This incident has been resolved.
Posted Jul 10, 2023 - 02:05 GMT+03:00

Investigating

We are currently investigating this issue.
Posted May 30, 2023 - 20:43 GMT+03:00
This incident affected: Games (Skywars, 0_0 Test Game).